[Updated 2013-04-19] PSO2: Translation Launcher v1.2.7

I'm sure PSO2 will get a US version some time this century. Meanwhile there is a patch and this is the forum where you can discuss it and get help with issues.

Re: [Updated] Phantasy Star Online 2: Translation Launcher

Postby Llama_Spit » Mon Aug 13, 2012 8:00 pm

[
Llama_Spit wrote:I also get another message saying " the patch you have loaded is either a)not compatible with the pso ver installed, b)not recognised by this application or out of date. Your pso files seems valid please proceed with caution." I really want to get this working but this seems more complicated than just manually compying the english patch in the directory, what am I doing wrong?


Update your patch, this is the message you will get when a new patch has been released.

viewtopic.php?f=4&t=206

I downloaded mirror 1, trusting all the others are the same. I just checked it before typing this and the CRC's are still the one's recognised by the app. It seems my app has done it's job telling you to update. I think I added an extra line into that error message for this version too suggesting you check the patch homepage.[/quote]

Yeah i'm also using the latest english patch from the mirror 1 link and its still saying that im using an "incompatible patch". So should I try all the mirrors and see if I magically get the launcher to detect one of them?

EDIT: Forgot to mention that I already patched the game manually, should I replace the patched files with original japanese files, to see if that works?
Llama_Spit
 
Posts: 2
Joined: Wed Mar 21, 2012 4:56 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby funkyskunk » Mon Aug 13, 2012 8:14 pm

This?

Incompatible Patch Installed
The files for PSO2 are not recognised by this application
Your patch will probably not work with this version of PSO2!


This means yes, your files are not correct so you need to get the official SEGA files again however you do it (re-install or whatever). The reason this is worded like this is because the same error will appear after SEGA update their files and we need to wait for a new translation patch.
funkyskunk
 
Posts: 189
Joined: Thu Aug 02, 2012 1:42 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby Link_of_Hyrule » Mon Aug 13, 2012 9:05 pm

It would be nice if the Application had a button that when you clicked it it told you which files didn't match the CRCs.
Link_of_Hyrule
 
Posts: 18
Joined: Fri Jun 29, 2012 8:00 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby funkyskunk » Tue Aug 14, 2012 7:26 pm

Excellent, we've got past bug reports and are on to suggestions again. It will take a while to get the options part finished as there are things the launcher creates and parts that the game creates so I need to get a way to read their script into my application properly.

As far as your suggestions go, this is something I planned to do already as I have a lot more room to play with now and I'm hoping to add a few things in at some point. For now though, here is a preview of the options section not available yet:

Image
funkyskunk
 
Posts: 189
Joined: Thu Aug 02, 2012 1:42 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby Link_of_Hyrule » Wed Aug 15, 2012 3:49 am

Looks awesome hopefully you get it out soon can't wait! I saw that other thread about the PSO2 Patcher it would be nice to get that integrated in as well since it's open source anyways. That way we can get the game patches and English patch all in one application :)
Link_of_Hyrule
 
Posts: 18
Joined: Fri Jun 29, 2012 8:00 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby funkyskunk » Wed Aug 15, 2012 11:26 am

I'll check out his source code, just need the links to download the files from really.
funkyskunk
 
Posts: 189
Joined: Thu Aug 02, 2012 1:42 am

Re: [Updated 2012-08-13] PSO2: Translation Launcher v1.0.4

Postby Link_of_Hyrule » Wed Aug 15, 2012 5:51 pm

I've never actually used this just saw it in the other post and thought it was a cool idea to have an English Launcher that would have all the functionality of the Japanese one plus a bit more.

https://github.com/Furyhunter/pso2-patcher/downloads
Link_of_Hyrule
 
Posts: 18
Joined: Fri Jun 29, 2012 8:00 am

Re: [Updated 2012-08-26] PSO2: Translation Launcher v1.0.5

Postby funkyskunk » Sun Aug 26, 2012 4:36 am

Updated original post with v1.0.5

Options do not save and do not show anything but default values...

...other than that, bug reports welcomed ;)
funkyskunk
 
Posts: 189
Joined: Thu Aug 02, 2012 1:42 am

Re: [Updated 2012-08-26] PSO2: Translation Launcher v1.0.5

Postby CyberMan » Sun Aug 26, 2012 10:47 pm

I've had the english patch version, but launcher writes that patch from 9th august is incompatible. It's only my error?
CyberMan
 
Posts: 46
Joined: Tue May 01, 2012 2:58 pm
Location: Ukraine

Re: [Updated 2012-08-26] PSO2: Translation Launcher v1.0.5

Postby funkyskunk » Sun Aug 26, 2012 11:43 pm

CyberMan wrote:I've had the english patch version, but launcher writes that patch from 9th august is incompatible. It's only my error?


Go to options >> functions and click "Analyse Installed Files" open the text file that creates and check all files say "crc match", if not then you can run a game update check which should fix any broken SEGA files. If the patch files are wrong then you should re-download the patch. If you like, you can paste the text file here and I'll tell you what's wrong, if anything.
funkyskunk
 
Posts: 189
Joined: Thu Aug 02, 2012 1:42 am

PreviousNext

Return to PSO2 Patch

Who is online

Users browsing this forum: No registered users and 5 guests

cron